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Typographic Conventions 

Type Style Description 

Example Words or characters quoted from the screen. These include field names, screen titles, 
pushbuttons labels, menu names, menu paths, and menu options. 

Textual cross-references to other documents. 

Example Emphasized words or expressions. 

EXAMPLE Technical names of system objects. These include report names, program names, 
transaction codes, table names, and key concepts of a programming language when they 
are surrounded by body text, for example, SELECT and INCLUDE. 

Example Output on the screen. This includes file and directory names and their paths, messages, 
names of variables and parameters, source text, and names of installation, upgrade and 
database tools. 

Example Exact user entry. These are words or characters that you enter in the system exactly as they 
appear in the documentation. 

<Example> Variable user entry. Angle brackets indicate that you replace these words and characters 
with appropriate entries to make entries in the system. 

EXAMPLE  Keys on the keyboard, for example, F2  or ENTER . 
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Document History 

Version Date Change 

1.1 09-Mar-2015 Corrected headings of section 3.1 and 3.2 

1.0 30-Jun-2014 Initial Release 
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1 Introduction  

This document provides information about Release 7.2, Service Pack 2 of the SAP Complex Assembly 
Manufacturing solution software suite. It is intended to inform and assist customers with understanding software 
enhancements or modifications for Release 7.2, Service Pack 2. For each enhancement, SAP provides a 
description of the modifications made to functionality or technology in the SAP Complex Assembly Manufacturing 
software suite.  

This document contains information pertinent to the core release of the SAP Complex Assembly Manufacturing 
software suite only. Customers that have specific functionality configured in the SAP Complex Assembly 
Manufacturing select layer may receive release notes as an addendum to this document or as an independent 
delivery item that is relevant to their particular implementation.  

SAP provides a number of modifications and enhancements as part of its software maintenance upgrade process. 
Some enhancements may require additional software configuration and training by an SAP representative. We 
encourage you to review each enhancement for its potential business benefit to your organization and then 
contact your SAP representative for information on implementation, deployment, and training. 

1.1 Software Modules Covered 

This document covers the following software modules:  

• Planning and Definition Modules: 
o Bill of Material Management (BOMM) 

o Computer-Aided Process Planning (CAPP) 

o Manufacturing Change Management (MCM) 

o Order Maintenance (OM) 

• Execution Modules: 
o Shop Floor Management (SFM) 

o Nonconformance Management (NCM) 

o Project Management Integrator (PMI) 

• Common (shared functions and utilities): 
o Electronic Callboard (CB) 

o First Article Inspection (FAI) 

o Time Sensitive Material (TSM) 

o Tool Control & Accountability (TC&A) 
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1.2 Implementation-Required Enhancements 

Some Release 7.2, Service Pack 2 enhancements require implementation or configuration by an SAP 
representative. Any enhancement that requires configuration for use is denoted by the symbol shown below. 
Please contact your SAP representative for additional information about these enhancements. 

 

1.3 Third-Party Software  

Support for the following has been discontinued in SAP Complex Assembly Manufacturing: 

• Cognos 

1.4 SAP Note 

The following SAP Note contains the most recent information on the release, as well as corrections to the Release 
Notes documentation. 

Make sure that you have the up-to-date version of the SAP Note, which you can find in the SAP Service 
Marketplace at service.sap.com/notes. 

SAP Note 
Number 

Title Description 

1983799 SAP Complex Assembly Manufacturing 7.2, 
Service Pack 2 Release Notes 

Information not included in or corrections to 
these release notes. 

1.5 Terminology 

Terms Description 

BOMM Bill of Material Management 

CAMS Complex Assembly Manufacturing solution 

CAPP Computer-Aided Process Planning 

CB Electronic Callboard 

CSS Customer Support System. The SAP issue tracking system. 

FAI First Article Inspection 

ITS The legacy Visual Intercept issue tracking system. 

MCM Manufacturing Change Management 

NCM Nonconformance Management 
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Terms Description 

OM Order Maintenance 

PMI Project Management Integrator 

SFM Shop Floor Management 

TC&A Tool Control and Accountability 

TSM Time-sensitive Material 
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2 Enhancements 

 Note 
This section includes screenshots showing SAP Complex Assembly Manufacturing applications as they 
have been implemented at SAP. Therefore, these screenshots may look different from your SAP Complex 
Assembly Manufacturing implementation. 

2.1 Planning and Definition Modules 

2.1.1 BOMM 

Auxiliary Data Collection (ITS42575) 

There is a new BOMM Aux Data Collection configuration parameter that governs when auxiliary data is collected 
when the order is worked in SFM. It has three options: 

• Parent Only: Data is collected when the part is manufactured, i.e., the parent order is worked. 
• Component Only: Data is collected when the part is consumed into a next assembly. (For a unitized 

installation kit [IK] part type this is the only option enabled.) 
• Both Parent & Component: Data is collected when the part is both manufactured and consumed. 

To set this configuration parameter in CAPP, select the Maintenance > Configuration Parameters > BOM menu 
and click the As Built Interface Parameters bar in the BOM Parameters dialog box. 

In the Identify Serial Parts Data dialog box, there is now an Aux Data Collection section with the three options 
shown below. (This dialog box appears by assigning a category to a serialized part and then clicking the ellipsis 
following the category field in the Part Master dialog box.) The default selection is Component Only. For any part 
type other than a unitized IK part type, the user can select a different option; however, the configuration 
parameter setting will override the user’s selection when the order is worked in SFM. 
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3D Import Success Indicator (ITS42737) 

Prior to this release, there was no message or visual indicator in the Visual Enterprise Assemblies dialog box 
confirming that a 3D BOM import was successfully done for the item selected in the tree. Now a check mark icon 
appears next to the item to show the import was successful. 

 

  



 

SAP Complex Assembly Manufacturing, Release 7.2, Service Pack 2 
Enhancements 

Release Notes 
© 2015 SAP AG or an SAP affiliate company. All rights reserved. 10 

 

2.1.2 CAPP 

Ability to Resize the Oper (Operation) Parts List Dialog Box (ITS42639) 

The Oper Parts List dialog box has been modified to allow users to resize it to see more or less of the graphic area 
or parts table. To resize, users can either click just above the graphic or on the small gray box on the left (both 
options are outlined in red below) and then drag the pane up or down. 

 

2.1.3 MCM 

There are no MCM enhancements. 

2.1.4 OM 

There are no OM enhancements. 
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2.2 Execution Modules 

2.2.1 SFM 

 Note 
Throughout this section, any references to operations also applies to steps.  

Serialized Parts Configuration Parameter (ITS40193) 

The new Display Cancelled or Scrapped Orders serialized parts configuration parameter determines if cancelled or 
scrapped orders can appear in the Serialized Parts dialog box. However, a user cannot make any changes to the 
cancelled or scrapped order when viewing it in the dialog box.  

The configuration parameter has four options: 

• Neither: Neithercancelled nor scrapped orders will appear. 
• Cancelled and Scrapped:  Both cancelled and scrapped orders will appear. 
• Cancelled: Cancelled orders only will appear. 
• Scrapped: Scrapped orders only will appear. 

To view these configuration parameters in SFM, select System > Configuration Parameters and then click the 
Serialized Parts Parameters bar in the Control Parameters dialog box 

Split Order Configuration Parameters (ITS40938) 

The current split process moves the split quantities using proportionality between the split quantity and the order quantity. 
The process uses the split ratio to determine the quantities moved, that is, rejected, completed, and ready quantities.  

This enhancement offers an alternative method via two new configuration parameters that will move a constant 
quantity from the parent to the child orders: 

• Split Quantity Usage: This configuration parameter has two options: Use Split Qty (Quantity) or Use Qty 
Ratio. If it is set to Use Qty Ratio, the split is done proportionally. 

• Keep Complete on Parent:  Depending on the setting for this configuration parameter, complete items are 
left on the parent order or they are moved to the child order. 

To set these configuration parameters in SFM, select System > Configuration Parameters and click the Order 
Parameters bar. 

Change Alert Order Comparison (ITS40960) 

 Note 
This enhancement requires that tkdiff has been installed and that SAP Complex Assembly Manufacturing 
has been configured for it as explained in the Installation Guide and Upgrade Master Guide.  

From the Acknowledge Change Alert window, users can now view a list of orders for the same plan and do a was/is 
comparison (similar to the CAPP document was/is comparison) to see the differences between orders.  
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To see the list of orders, the user clicks the new Show Orders for Plan button in the Acknowledge Change Alerts 
window. This button is only visible when acknowledging change alerts, not viewing them.  

 Note 
Clicking this button does not acknowledge the change alert. The user must click the Acknowledge button. 

 

Clicking the Show Orders for Plan button opens the Order Compare List dialog box listing the orders for the same 
or prior revisions of the plan. For example, if there are five revisions of the plan and the order for which the user is 
acknowledging the change alert was created from revision four, users will only see orders created from revisions 
one through four. As with other SFM screens and dialog boxes, this dialog box can be configured using the Window 
> Screen Label Configuration menu to change the column names and the Window > Screen Configuration menu to 
change the column order and show or hide columns. 

 

To compare, the user selects the order to compare against the current order and clicks the Show Diff button. This 
opens the tkdiff program showing the changes between the orders.  

 Note 
Clicking the Show Diff button does not acknowledge the change alert.  The user must click the 
Acknowledge button. 
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Redesigned Employee Master User Interface (ITS41184) 

The Employee Master user interface (UI) has been redesigned to improve performance, to make it easier to find 
and work with users and logons, and to combine disparate functions into one place. 

There are now separate tabs for Logon Maintenance and for User Maintenance. Each tab includes several fields at 
the top that allow you to search for the logon ID or user ID that you want to edit rather than having to scroll 
through all logons or users to find the one to update. 

 

The Logon Maintenance tab has three tabs: 

• Logon Accounts: This tab, shown above, lists the results of a logon ID search.  It also has a Copy button to 
copy the selected logon ID to create a new one and a Delete button to remove the selected logon ID.  
In addition, it includes a table on the right listing the available logon profiles. In prior releases, logon 
profiles were accessed from a separate Logon Information dialog box. Using the Delete Profile button just 
below the table, you can delete the selected profile. 

• Logon ID Maintenance: This tab is used to add new logon IDs or edit existing ones. Double-clicking on a logon ID 
on the Logon Accounts tab will populate the Logon ID Maintenance tab with that logon ID’s data as shown below.  
Selecting this tab without selecting a logon ID on the Logon Accounts tab allows you to create a new 
logon ID by completing the fields and then clicking Apply. Once the logon ID is created, you can then use 
the other buttons to assign a profile or permissions, work locations, sites, etc., to the logon ID. 
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• Logon Profile Maintenance: This tab is used to add new logon profiles or edit existing ones. Double-
clicking on a logon profile on the Logon Accounts tab opens this tab and shows the permissions assigned 
to the profile and those available for assignment. In prior releases, permissions were assigned via a 
separate Permissions Assignment dialog box.  
Selecting this tab without selecting a logon ID on the Logon Accounts tab allows you to create a new 
logon profile by completing the Profile Name and Description fields and then assigning permissions. 

You can temporarily grant or revoke an assigned permission by right-clicking on it and clicking the Toggle 
Permission button shown below. This button replaces the Permission Grant/Revoke button. 

 

The User Maintenance tab also has three tabs: 

• User Accounts: This tab lists the results of a user ID search. It also has a Copy button to copy the selected 
user ID to create a new one and a Delete button to remove the selected user ID. 
In addition, it includes a table on the right listing the available user profiles. In prior releases, user profiles 
were accessed from a separate User Information dialog box. Using the Delete Profile button just below the 
table, you can delete the selected profile. 
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• User ID Maintenance: This tab is used to add new user IDs or edit existing ones. Double-clicking on a user 
ID on the User Accounts tab will populate the User ID Maintenance tab with that user ID’s data as shown 
below.  
Selecting this tab without selecting a user ID on the User Accounts tab allows you to create a new user ID 
by completing the fields and then clicking Apply. Once the user ID is created, you can then use the other 
buttons to assign a profile or permissions, work locations, groups, sites, etc., to the user ID. 

 

• User Profile Maintenance: This tab is used to add new user profiles or edit existing ones. Double-clicking 
on a user profile on the User Accounts tab opens this tab and shows the permissions assigned to the 
profile and those available for assignment. In prior releases, permissions were assigned via a separate 
Permissions Assignment dialog box.  
Selecting this tab without selecting a user ID on the User Accounts tab allows you to create a new user 
profile by completing the Profile Name and Description fields and then assigning permissions. 

You can temporarily grant or revoke an assigned permission by right-clicking on it and clicking the Toggle 
Permission button shown below. This button replaces the Permission Grant/Revoke button. 
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From any of the tabs you can click the following buttons: 

• Print Assignments: Clicking this button opens the Assign User Reports dialog box from which you can 
assign reports to the different logon types. 

• Security Audit: Clicking this button opens the Security Audit dialog box from which you can view the 
history of changes made to logon IDs or user IDs. 

• Failed Login: Clicking this button opens the Failed Login Attempts dialog box listing failed logins to SAP 
Complex Assembly Manufacturing. 

Unplanned Removals Validations (ITS41266) 

The unplanned removals functionality has been updated to validate the following when users add parts to a 
removal record: 

• If a removed part requires a serial number or unique identification (UID) data that the serial number or 
UID data are collected before the part can be added to the removal record. 

• If a removed part does not require a serial number or UID data that a serial number or UID data cannot be 
entered before the part is added to the removal record. 

If a part instance is installed with a serial number or UID data and the user attempts to remove it without a serial 
number or UID data, the following error appears. The user must enter the serial number or UID data in order to 
continue with the removal process. 

 

If a Part Master exists for the part and it does not require a serial number or UID data but the user has entered a 
serial number or UID data, the following error appears. The user must clear the entries to continue with the 
removal process. 

 

If as-built bill of material (ABOM) data does not exist for the part the user is removing but there is a Part Master for 
it, the system allows the removal and uses the Part Master to validate what data is required for the part: 

• If the part is serialized or requires UID data but the user does not enter it, the first error message shown 
above appears. 

• If the part is not serialized or does not require UID data but the user enters the data, the message shown 
just above appears.  
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Again, the system stops the removal process until the issue is corrected. The question shown below then appears. 
If the user clicks Yes, the removal process continues. If the user clicks No, the part is not added to the removal 
record and the user is returned to the Removal Parts dialog box so he or she can enter a different part or cancel 
out of the process. 

 

New Hold and Release Hold Logon Permissions (ITS42583) 

Prior to this release, holding and releasing orders or operations were controlled by either user permissions or no 
permissions at all. The following logon permissions have been added: 

• Access to Display Hold Notes: This allows the logon ID to view the Hold Notes dialog box. 
• Access to Hold Operation: This allows the logon ID to view the Hold Reason Codes dialog box when 

holding an operation. 
• Access to Hold Order This allows the logon ID to view the Hold Reason Codes dialog box when holding an 

order. 
• Access to Release Hold on Operation: This allows the logon ID to access the release operation hold 

function. 
• Access to Release Hold on Order: This allows the logon ID to access the release order hold function. 

New Removal Record Logon Permissions (ITS42621) 

The following logon permissions have been added for removal 
records. These allow the logon ID to view the functions noted below in 
the right-click menu in the Create/Edit/View Removal Record dialog 
box: 

• Access to Removal Record - Add Part: 
• Access to Removal Record - Edit Part 
• Access to Removal Record - Delete Part 
• Access to Removal Record - Reinstate 
• Access to Removal Record - Collect Aux (Auxiliary) Data  

See the next enhancement for information on two additional 
functions that have been added to the menu—Set Part to Removal 
Only and Reverse Part From Removal Only. 
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Unlocking a User’s Own Lock on Shop Text (ITS42804) 

SFM can now be configured to allow a user to unlock the lock that user put on shop text in another SAP Complex 
Assembly Manufacturing login session.  

There are two new configuration parameters for this enhancement. To view these configuration parameters in 
SFM, select System > Configuration Parameters and then click the Shop Display Parameters bar:  

• Allow Same User to unlock text lock allows the same user who locked the operation for shop text data 
collection to unlock it. It can be set to Yes or No. 

• Show Unlock Warning controls whether or not a warning displays when the user who locked an operation 
for data collection is the same user unlocking the data collection. It can be set to Yes or No. 

If unlocking is allowed and the Show Unlock Warning configuration parameter is set to Yes, when the user 
attempts to unlock shop text that he or she has locked the following message appears: 

• If the user clicks Continue, the lock is released and the user can enter data but with the possibility of data 
loss as noted.  

• If the user clicks Cancel, the operation lock remains in place and no edits are allowed. 

 

When the session lock is released or changed to another session, in the other session the user will see the 
following message when the user tries to save any changes he or she made. Once the user clicks OK, the data 
refreshes to show that entered and saved in the other session.  
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Unplanned Removals for Nonunitized Orders (ITS43099, ITS44122, and 
CSS742054)  

In prior releases, SAP Complex Assembly Manufacturing only supported unplanned removals for unitized orders.  
Also, when a part was removed through the unplanned removals process and was not replaced, the removal order 
could not be closed. This enhancement now allows unplanned removal orders to be created for nonunitized orders 
if preferred. It also allows parts to be removed without requiring the reinstallation of replacement parts for both 
unitized and nonunitized orders. 

The new Unplanned Removals Availability configuration parameter determines the order types for which 
unplanned removals can be done. It has four options: 

•  None: Unplanned removals are not allowed for any order types. 
• Assembly Only: Unplanned removals can only be done for assembly (unitized) orders. 
• Fabrication Only: Unplanned removals can only be done for fabrication (nonunitized) orders. 
• Both: Unplanned removals can be done for either order type. 

The default setting for this configuration parameter is Assembly Only. To view this configuration parameter in 
SFM, select System > Configuration Parameters and then click the Serialized Parts Parameters bar: 

The Create Removal Order dialog box, which appears after a user selects the Create Removal Record shortcut 
menu option, now has a Serial Number field as shown below. This field is only enabled for nonunitized orders and 
is required. If there are multiple serial numbers for the parent part, the user can select the appropriate one using 
the drop-down. For unitized orders, the existing End Item field still applies and is enabled.  
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The Removal Parts dialog box, which appears when a user right-clicks in the Create/Edit/View Removal Record 
and selects Add Part, now includes a Removal Only check box. If this check box is selected, the part can be 
removed and reinstallation is not required.  

 

On the Create/Edit/View Removal Record dialog box, the new Removal Only column lists Yes for any part 
designated as such or No for any part that requires reinstallation. 
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Users can also designate a part as removal only using the new Set Part To Removal Only option in the right-click 
menu. They can also clear a part’s designation as removal only using the new Reverse Part From Removal Only 
menu option. These options are only available for parts with a status of Identified or Removed. They are also only 
enabled for a user assigned the following permissions: 

• Removal Record Revert Part From Removal Only   
• Removal Record Set Part to Removal Only 

Or for a logon ID assigned the following permissions: 

• Access to Removal Record – Reverse Part From Removal Only  
• Access to Removal Record – Set Part To Removal Only 

When a removal-only part is bought off, its status immediately changes to Boughtoff. It is not required to go 
through the production, quality, and customer inspections like a part that requires reinstallation. If the buyoff is 
undone, its status reverts back to Removed.   

Please note that for a fabrication part number for an order with a quantity greater than one, any part that must be 
replaced can only be replaced by the same part number with the same or a different serial number.  

There are also two other new configuration parameters for this enhancement. To view these configuration 
parameters in SFM, select System > Configuration Parameters and then click the Order Parameters bar:  

• Allow Closure with Open UPR (Unplanned Removal) Orders allows you to make it a requirement that all 
unplanned removal orders must be completed before an order is closed. It can be set to Yes or No. 

• The Use WSP (WIP_SERIALIZED_PARTS) to Filter Fab UPR Parts uses the contents of the 
WIP_SERIALIZED_PARTS table to filter the list of parts presented to the user to only those that are 
related to the fabrication orders that captured that part when the user is adding parts to a removal order. 
It can be set to Yes or No. 

Scanning Operations in Batches (ITS43124) 

There is a new Auto Select Batch Operations configuration parameter that controls whether auto-selection of selected 
operations or all operations by work center is done when scanning or entering candidate orders for a batch. To set this 
configuration parameter in SFM, select System > Configuration Parameters and click the Order Parameters bar.  

If the configuration parameter is set to Selected, after 
the user enters or scans orders into the Work Orders for 
Batch Process dialog box and clicks Submit, the 
Available Operations dialog box shown appears with a 
list of valid operations for the first order in the batch. The 
user selects the desired operation and clicks OK, which 
adds the operation to the batch. For each subsequent 
order, the system automatically selects the next Not 
Started operation in the same work center and adds it to 
the batch. If the system cannot find a Not Started 
operation for an order in that work center or if the Not 
Started operation is in a different work center, it is not 
added to the batch.  

If this configuration parameter is set to All, once the 
user clicks Submit all operations on all the orders for 
the same work center are added to the batch list. 
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Batch Start Prompts (ITS43201) 

In the past when a user started a batch, the Start Operation in Setup Mode question appeared for every order in 
the batch. Now the user is prompted only once per batch.   

New Tool Order List Screen (ITS44086) 

There is a new Tool Order List screen that is accessed via the Order Functions menu or function panel.  Like the 
Order List screen, the Tool Order List includes search fields that allow users to find and view tool orders by tool 
number, end item, order status, hold code, work center, site code, or from and to date.  

Once users have found tool orders using the search fields, they can filter the order list using the Tool Order Filter 
button. Clicking this opens the Tool Order List Filters dialog box with additional fields to filter by, such as Tool Base 
No (Number), Tool Left Dash number, or Tool Code. When the Tool Order List is filtered, the button turns green as 
shown below. 

 

To view this screen, users must have a logon profile that is assigned the new Access to the Tool Order List 
permission. 

As with other screens in SFM, you can change the names of the columns on the Tool Order List using the Windows 
> Screen Label Configuration menu. You can also change the column order and layout using the Window > Screen 
Configuration menu.   
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Capturing User Comments and a New Activity History Column (ITS45297) 

Shop Floor Management can now be configured to capture user comments when they perform the following 
transactions: skip an operation, undo skip operation, unstart an operation, reopen an order, cancel an order, undo 
cancel order, scrap an order, undo scrap order, and undo operation completion. The comment is added to the 
Activity Description section of the Activity Records dialog box, which is accessed by selecting an order on a screen 
and  then selecting Activity History in the General Functions function panel or menu.  

  

In order to capture these comments, the new Capture Comment for Activity History configuration parameter must 
be set to Yes. To set this configuration parameter in SFM, select System > Configuration Parameters and click the 
Order Parameters bar.In addition, the User ID and User Stamp columns can now be added to the Activity Records 
dialog box to help distinguish users with the same User Name. These columns list the values from the user’s User 
ID and Inspection Stamp fields in the Employee Master. To change the column names, if desired, select Window > 
Screen Label Configuration and then select Activity History in the Screen Name drop-down field. To make the 
columns visible and change their placement in the Activity Records dialog box, select Window > Screen 
Configuration and then select Activity History in the Screen Name drop-down field.  

Option to Add a Custom Button to the Serialized Parts Dialog Box (ITS45458)  

Your SAP representative can configure the Serialized Parts dialog box to include a custom button that, when 
clicked, performs a specified command. The button name and the command to be executed must be defined in 
the following new configuration parameters. To set these configuration parameters in SFM, select System > 
Configuration Parameters and click the Serialized Parts Parameters bar: 

• Optional Button Label: This should list the button name. 
• Optional Button Command: This should list the command to be called when the button is clicked. 
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2.2.2 NCM 

Signoff E-mail Enhancements (ITS42576)  

Your SAP representative can configure the e-mail messages that are sent during signoff to include a more 
informative subject line and message. For example, the subject can be enhanced to include the nonconformance 
record (NCR) number and the discrepancy number, and the message can include such information as the NCR 
type, discrepancy number, and the signoff status (approved or rejected).  

Resubmit Buyoff and Discrepancy Text Enhancements (ITS42800)  

Your SAP representative can configure NCM to append comments to the discrepancy text or buyoff text when a resubmit 
is done either from SFM or within NCM. For example, if a user does a resubmit from SFM, the user’s ID and name and the 
text the user entered in the SFM Resubmit Comments dialog box can appear in the Discrepancy Text section. 

New Configuration Parameters (ITS43354)  

There are two new configuration parameters your SAP representative can use if special handling is required for 
creating or appending to rework orders. To view these configuration parameters in CAPP, select Maintenance > 
Configuration Parameters > NCM and then click the SFM Interface Parameters bar: 

• Customer Append to Rework Order Proc: This parameter indicates the customer-specific procedure 
name to use to append to rework orders  

• Customer Create Rework Order Proc: This parameter indicates the customer-specific procedure name to 
use to create rework orders. 

2.2.3 PMI 

There are no PMI enhancements. 

2.3 Common 

2.3.1 CB 

Option to Remove Buyoff Call Prompt (ITS43121) 

The new Automatic Prompt for Buyoff Call configuration parameter determines whether or not users are 
prompted to send a buyoff call upon completion of an operation/step with a P (production) inspection stamp 
followed by an operation/step with a Q (quality) or C (customer) inspection stamp. If this is set to Yes, the Do you 
want to send a buyoff call message will appear on operation/step completion, and users will have the option to 
send or not send the buyoff call. If this is set to No, the message no longer appears and no call is sent. The default 
setting is Yes. 

To set this in SFM, select the System > Configuration Parameter menu and then click on the Callboard Parameters 
bar. 
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Callboard E-mail Notifications (ITS42579) 

The notification functionality in Callboard has been expanded to send e-mail notifications to more recipients when 
requesting, responding to, updating, or completing buyoff or freeform calls.  

In prior releases, e-mail notifications were only sent to the custodian of the callboard subgroup to which the call 
was sent if the Custodian Notification: Email check box was selected for the subgroup. Now, e-mail notifications 
can also be sent to the call requestor and the user who responds to the call.  

In addition, the e-mail content has been enhanced to provide more details about the call, such as the subject, the 
call ID, the sending callboard name, the receiving callboard name, the call requestor’s name, and the call 
responder’s name.  

This enhancement requires that the following new configuration parameters be set. To set them in SFM, select the 
System > Configuration Parameter menu and then click on the Callboard Parameters bar: 

• Send Notification to Call Requestor: If this parameter is set to Yes, a copy of the callboard e-mail 
notification is sent to the call requestor. 

• Send Detailed Notification E-Mail:  If this parameter is set to Yes, the contents of the e-mail will include 
detailed information about the call being sent. 

• Notification on Any Callboard Activity:  If this parameter is set to Yes, e-mail notifications are sent for a 
call response, call request, and call completion. 

• Send HTML E-Mail Notification: If this parameter is set to Yes, e-mail notifications sent to external e-mail 
addresses are sent as HTML-formatted e-mails. 

This enhancement also requires that users have e-mail addresses set up for their user ID in the Employee Master. 

2.3.2 FAI 

First Article Iterations (ITS42808) 

The First Article Inspection create iteration function was called in a mix of places in SAP Complex Assembly 
Manufacturing—sometimes by automatic events under certain conditions and manually via the Edit > New 
Iteration menu option in the First Article Requirement Record (FARR). This sometimes caused confusion as to 
when and how new FARR iterations were created.  

This enhancement now limits iteration creation to the Edit > New 
Iteration menu option to provide a simpler and easier interface for 
FAI users.  When a user selects this menu option, the Create New 
Iteration dialog box appears. It allows the user to indicate whether or 
not to apply the iteration to the current and any subsequent plan 
revisions or to all plan revisions. The user also has the option to 
remove the current plan revision from being covered by the previous 
iteration by selecting the Remove current revision from previous 
iterations check box. 

If there is a working First Article Inspection Record (FAIR) in the 
shop, the user can apply the new iteration to it by selecting the 
Apply new iteration to working FAIR check box.  If the user selects this option, the FAIR is put on hold until the new 
iteration requirement is set to ACTIVE and the changes are propagated to the FAIR. 
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2.3.3 TSM 

TSM Storage Module Original Expiration Date Column (CSS3393306) 

An Original Expiration Date column has been added to the TSM Storage module so that when a user updates the 
expiration date of TSM, the original expiration date is still visible. This allows material managers to more readily 
determine what material is the oldest.    

 

Issue Time Sensitive Material/Ply Kit and Return Time Sensitive Material /Ply 
Kit Screen Configuration (ITS40479) 

In the Issue Time Sensitive Material /Ply Kit and Return Time Sensitive Material/Ply Kit dialog boxes, the remaining lives 
were not shown so there was no way for operators to easily see the amount of life left for time-sensitive materials.  

To help make an informed decision before selecting materials, the following fields can now be added to the Issue 
Time Sensitive Material /Ply Kit dialog box using the SFM Window > Screen Configuration functionality:  

• Issue Date 
• Remaining Mechanical Life (Hrs) 
• Remaining Floor Life (Hrs) 
• Remaining Handling Life (Hrs) 
• Remaining Shelf Life (Hrs) 
• Roll  
• Root Distinct ID 
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Also, the lower section of the Issue Time Sensitive Material /Ply Kit dialog box, which lists the material that can be issued 
to the order, can now be configured; in the past, this was not an option. You can add the following fields to this section: 

• Distinct ID • Expiration Date 

• Handling Life (Hrs) • Issue Date  

• Location • Lot Number 

• Max Floor Life (Hrs) • Mechanical Life (Hrs) 

• Original Distinct ID • Original Expiration Date 

• Remaining Floor Life (Hrs) • Remaining Handling Life (Hrs) 

• Remaining Mechanical Life (Hrs) • Remaining Shelf Life (Hrs) 

• Roll • Root Distinct ID 

• Status • Sub Location 

The following fields can now be added to the Return Time Sensitive Material /Ply Kit dialog box using SFM Window > 
Screen Configuration functionality: 

• Handling Life (Hrs) • Issue Date 

• Max Floor Life (Hrs) • Mechanical Life (Hrs) 

• Remaining Floor Life (Hrs) • Remaining Handling Life (Hrs) 

• Remaining Mechanical Life (Hrs) • Remaining Shelf Life (Hrs) 

• Roll  • Root Distinct ID 
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As with many SFM screens and dialog boxes, the field names listed above are configurable using the Window > 
Screen Label Configuration menu. 

TSM Not Consumed Warning Message (ITS40519) 

In the past, when an operator completed an operation that had TSM on it that had not been consumed, a warning 
message would appear. Once the operator acknowledged the warning message, the operator could complete the 
operation. Since the warning only appeared for operations with TSM on them, other operators might not know 
that TSM had not been consumed until they attempted to complete and close the order.  

Now, a warning that TSM has not been consumed can appear for every operation in an order that has 
unconsumed TSM regardless of whether or not the operation has TSM on it. To have the warning appear for all 
operations, the new configuration parameter Display Error Message on All Operations must be set to Yes. If it is set 
to No, the warning will continue to appear only for operations with unconsumed TSM.  

To set this configuration parameter in SFM, select the System > Configuration Parameter menu and then click the 
Time Sensitive Material bar.  

Only operators with the user permission Clear Comp Oper: Bypass TSM Edit permission can override the warning 
and continue with operation completion. 

New Issue Material Configuration Parameter (ITS40593) 

There is a new TSM Issue Material Process configuration parameter with three options that controls when material 
can be issued to orders and what materials appear in the issue material list: 

• Issue Material if TSM Status = 'IN': Only material with a status of IN can be issued to orders. 
• Issue Material if TSM Status = 'OUT': Only material with a status of OUT can be issued to orders. 
• Issue Material if TSM Status = 'IN' or 'OUT': Material with a status of IN or OUT can be issued to orders.  

To set this configuration parameter in SFM, select the System > Configuration Parameters menu and then click 
the Time Sensitive Material bar.  
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New and Removed TSM Logon Permissions (ITS41418)  

Four TSM logon permissions have been removed and replaced with nine new logon permissions to more tightly 
control the TSM functions users can perform.  

The following permissions were removed: 

• Access to Layup Apply Material/Set Ply Status  
• Access to Layup Complete Layup 
• Access to Layup Create/Edit Kit 
• Access to Layup Delete Kit 

The following permissions were added. These allow the logon ID to view the functions noted below in the right-
click menu in the Order Ply List dialog box, which is accessed via the Shop Display > Order Ply List menu: 

• Access to Apply Material 
• Access to Apply Material to All 
• Access to Complete Layup  
• Access to Complete Layup To All 
• Access to Create Ply Kit  
• Access to Delete Ply Kit 
• Access to Edit Ply Kit  
• Access to Set Ply Status to Compacted 
• Access to Undo Apply Material  

 

In addition, the Set Ply Status to In Cure option has been removed from the right-click menu. It performed the 
same function as completing the layup so it was unnecessary.  

Kit and TSM Storage Module Enhancements (ITS44028) 

The TSM functionality has been enhanced to allow the creation of kits for an order, for the order to close with plies 
in Stopped status, and for the plies to transfer to a parent order at another time. The system also now 
automatically creates kit IDs—users no longer have to manually enter them. Also as part of this enhancement, 
multiple rolls can be received at one time in the TSM Storage Module, and multiple rolls or kits can be selected at 
one time to do functions against them. 

This enhancement requires that an “uncured” synthetic part number is created in BOMM as a component of the 
parent part used for the layup of the part. The uncured synthetic part number is used for kit cutting only, not 
curing, and allows the order for these kits to close when the plies are in a Stopped status. In BOMM, a parent part 
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can have only one uncured synthetic component; however, the system does not validate that there is only one 
such component. The uncured synthetic part number should be the only part directly below the parent in the 
BOM. Also, the parent part number and the synthetic part’s first 15 characters must match.  

 

As part of this enhancement there is a new BOMM Uncured Plies Part Types configuration parameter that should 
list the part types that are uncured types. To set this in CAPP, select Maintenance > Configuration Parameters > 
BOM and click the Part Parameters bar. 

There are also two new CAPP configuration parameters. To set the following in CAPP, select Maintenance > 
Configuration Parameters > CAPP and click the Miscellaneous Parameters bar: 

• Uncured TSM Plan Sub-Type: This parameter indicates the plan subtype value or values that flag a plan 
that includes uncured TSM plies. It is used in conjunction with the Uncured Plies Part Types configuration 
parameter discusssed above. When there is a parent plan that contains any component parts that have 
an Uncured Plies Part Type value, the TSM plies on this plan that are also contained in the plan for the 
uncured plies synthetic TSM part must be identified on the parent plan with a U in the Ref field (discussed 
later in this section) in the TSM ply list. 

• Compare Uncured Parent/Child Ply Lists: This parameter indicates whether or not the TSM ply lists of 
parent and child plans that include uncured TSM plies should be compared for mismatches. If this is set 
to Yes and there are are mismatches, a warning message is presented to the user, but it does not prevent 
the user from saving either of the plans as Complete.  
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In CAPP, there is a new Uncured plan subtype 
in the Valid Plan Subtypes table for 
fabrication plans. To view or edit this table in 
CAPP, select Maintenance > Validation Table, 
select Valid Plan Subtypes in the Table 
Maintenance Selection dialog box, and click 
Edit Data. 

The uncured synthetic part should be the 
only part within the parent BOM with a plan 
that has an Uncured plan subtype.   

The ply tables in the parent and uncured 
synthetic plans should be the same, except 
for the Ref (reference designator), Kit 
Assignment # (Number), Layup Oper, Cure 
Oper, and Compaction Oper columns. As explained above, if the Compare Uncured Parent/Child Ply Lists 
configuration parameter is set to Yes, then the planner is warned if the plans are not the same. 

The Kit Assignment # column is a new column that allows a planner to identify what kit the plies belong to. This is 
useful when a kit may be so large that it needs to be broken down into multiple kits. It allows users to leave kits in 
the freezer, for example, until they are ready to issue the plies in the kits to the parent.  

Plies with a Ref value of P or blank can be put into kits1; plies with a Ref value of S, R, or N cannot be put into kits. If 
plies in the table have a value of either P or blank, then the planner can enter a number, up to three digits, in the Kit 
Assignment # column for these plies. If a number is entered, then every ply with a Ref value of P or blank in the 
table must have a number; the column cannot be blank. 

 Note 
You can change the name of the Kit Assignment # column in SFM using the Window > Screen Label 
Configuration menu. Select the TSM –Plan Ply List or TSM – Order Ply List screen. You can change where 
the column appears in the dialog box using the Window > Screen Configuration menu. 

                                                                        
1 Ref values: N indicates a nonvalidated ply that is not tracked and does not have a Part Master; P indicates a child ply (can be 
used in kits); R indicates a reference ply that is not tracked; S indicates a parent ply (synthetic, reference); U indicates a ply that 
will receive materials from a kit; and blank is for a regular ply that can be used in a kit. 
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Planners should first build the ply list for the parent plan. The raw material for the child plies should have a Ref 
value of U as shown in the example below. For items with a value of U, the system only verifies that the material 
exists in a BOMM Part Master. It does not validate that the part exists in the plan’s parts list or the MBOM of the 
parent part. 

 

The ply list of the parent should then be copied to the ply list of the child synthetic’s plan using the Edit > Copy 
menu. Any raw material with a U reference value on the parent’s ply list should now be changed to P or blank as 
shown below. The child ply list should not have any U reference designators; however, the system does not 
validate this. The planner must still confirm that all the applicable parts from the BOM (any ply set to anything 
other than U or N) have been consumed accurately into the plan. 

 

During the save complete of the plan, CAPP retrieves a distinct list of all material from the ply list where the Ref is 
U.  If the given material does not already exist in the operations’ parts list (regardless of part quantity or callout 
type), CAPP will systematically insert that material as a reference component part into the parts list with a zero 
quantity. This insert occurs just prior to the validation step that identifies missing TSM raw material from the parts 
list. As part of this step, the system will never systematically delete any reference parts from the parts list.  Any 
removal of system-added reference parts is the user’s responsibility. 
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The following rules apply to any SFM orders created from plans with the Uncured subtype: 

• The orders can close with uncured TSM plies on them. However, the plies must have a status of Stopped.  
• Plies with a compact operation requirement will not change to Compacted status when the compact 

operation is completed. 
• Plies with a complete operation requirement will not change to Complete status when the complete 

operation is completed. 

In SFM, the Create Ply Kit function now takes into account the kit assignment number.  When the Create Ply Kit 
function is used on an uncured order with no kit assignment numbers, the Create Ply Kit dialog box appears listing 
the plies available for kitting and the user must manually select one or more plies for the kit. The Kit ID field is now 
disabled so the user can no longer enter a kit ID number. Once the user clicks OK or Apply, the system 
automatically assigns a kit number in the format order number-next sequential kit number, e.g., 
L000000000002994-001 as shown. 

When the Create Ply Kit function is used on an uncured order with kit assignment numbers, the system 
automatically creates the kits and posts a message listing all the kits that have been created for the order once 
the creation is finished.  

 

Kits are still issued using the Issue Kit function in SFM.  The Issue Time Sensitive Material/Ply Kit dialog box will list 
available kits created for the selected order and for the synthetic part number in the order’s parts list.  The system 
checks that once multiple kits have been selected for a parent order, all of the sibling kits are issued to that same 
parent order; kits cannot be issued to different parent orders. The issue of all the kits, however, can happen at 
different times. If there are any mismatches or a ply table does not exist for the parent part, the system will display 
an error message. (It is considered a match if the following columns are the same between the parent and the 
child ply list: Seq, Ply Number, Part Number, and CAGE Code, but NOT by operation number.)  

Once a kit is issued to a parent 
order, the kit number becomes 
inactive and cannot be used again. 
All the time data that was gathered 
on the synthetic order ply table is 
moved to the parent ply table and 
the status becomes OUT. The 
system will then follow the same 
logic used for regular TSM orders 
where plies must be in a Completed 
status before the parent order can 
be closed. 

Also the Apply Material and Apply 
Material To All functions now ignore 
any plies with a Ref value of U. If a user selects either function for plies with a value of U, an error appears stating 
that the ply must get its material information from a kit.  
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In the TSM Storage Module, users can now receive multiple rolls at once. Selecting the Receive Multiple Rolls check box 
on the TSM Receive Material screen adds a # of Rolls field into which the user can enter the number of rolls. Based on 
the number entered, the system adds a row for each roll. The user must enter a roll identifier in the Roll column and can 
enter a Distinct ID value or leave that column blank to have the system assign the next ID number to the roll. 

  

Finally, users can select mutliple rolls or kits at one time to do selected functions for them. The Select Mode field 
will list either Single or Multi to indicate whether users can select only one roll or kit in the search results or 
multiple rolls or kits at once. When Select Mode is Multi, users can select multiple rolls or kits and (depending on 
the status) issue rolls to a work center, update the location of rolls or kits, return the rolls, or inactivate the rolls. 

To be able to select multiple rolls or kits, the following search fields must be set as noted: 

• The SFM or SFM Kit option must be selected. 
• TSM Status must be set to In, Out, or Exp-Out (Expired Out). 
• Rolls Only must be set to Yes if the SFM option is selected. 
• There must be entries in the Location and Sub Location fields. 
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2.3.4 TC&A 

There are no TC&A enhancements. 

2.3.5 Shared 

Standard Library View-only Message (CSS520007) 

If a user logs into SAP Complex Assembly Manufacturing and immediately selects an option in the Maintenance > 
Standard Library menu, the message below now appears. In prior releases no message was presented so users 
did not understand why they could not make edits. A user must access a document type, e.g., an installation or 
fabrication plan, in order to open the Standards Library in edit mode.  
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3 Issues Addressed 

The following tables list the issues addressed in this release. 

3.1 Planning and Definition Modules 

3.1.1 BOMM 

SAP 
Reference 

Description Priority 

CSS152218 Oracle error when importing 3d model with no instance data Medium 

CSS154683 Error message when using Delete All Components in an MBOM with plants active. High 

CSS154741 Error message Bad Window Path Name "bommaintenance". High 

CSS19122 Backslashes being added when BOMM part parameter configurations are saved.  High 

CSS210110 When importing from Visual Enterprise Generator, material masters should not 
update. 

Medium 

CSS30982 Bulk indicator issue. Medium 

CSS3725457 ABOM tree is not expanding. Medium 

CSS4385532 Component parts missing in ABOM tree for a fab order. Medium 

CSS4475913 BOM import is failing. Medium 

CSS4781736 Issues allocating components when SAP Complex Assembly Manufacturing is 
integrated with Visual Enterprise but no model exists for the given EBOM or 
MBOM. 

High 

CSS512219 Get an error when switching from MBOM/ABOM to SBOM. Medium 

CSS742409 Remove and replace does not handle removing and replacing the same 
part/serial number multiple times, which causes an ABOM issue. 

High 

CSS761986 ABOM issue on remove only function. Medium 

CSS79463 MBOM effectivity error message issue. Medium 

ITS36991 There are significant performance issues when importing large sets of part 
masters. 

High 

ITS40065 ABOM retrieval time is excessive. Low 

ITS40508 Cannot release the BOM and the plan together with a save Complete. High 

ITS41345 Error with up-revving a released to MRP phantom. High 

ITS42483 Error encountered using the Correct Serial shortcut menu option in ABOM. High 

ITS42663 Error message in MBOM after selecting a part to add to the MBOM in the list view. Low 

ITS42759 Issues with ::hmsBom::RecLoadFabPartListDataValues and 
::hmsBom::RecLoadFabPartListDataValuesBind. 

Low 
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SAP 
Reference 

Description Priority 

ITS43939 MBOM incorporation is creating duplicate component requirements. High 

ITS44013 Removed part has an invalid UID construct value in ABOM. Medium 

ITS44268 Need a change to the procedure ::hmsBom::SFMMbomCompare to support a 
requirement that adds an additional key field (Reference Designator) to the part 
usage of a component. The procedure must account for additional fields making 
the item unique. 

Low 

ITS45075 Adding component freezes BOMM. High 

3.1.2 CAPP 

SAP 
Reference 

Description Priority 

CSS106047, 
CSS106048,  
and 4065831 

Error when releasing routing to SAP ECC (step installation plan). Medium 

CSS1455454 Duplicate apostrophe in operation text. Medium 

CSS154755 Error message when saving plans complete. High 

CSS187041 Routing errors for document type CREATE_SAPROUTINGRELEASE_001: sending 
messages more than one time, trigged by saving a plan complete. 

High 

CSS2004780 Illegal variable name/number when saving an installation step plan complete. Medium 

CSS210374 Releasing a standard plan tries to send a routing to SAP ECC. Medium 

CSS221540 Operation precedence does not work properly; database error. High 

CSS224865 Site not being populated on the plan header. Medium 

CSS263082 Frozen standard text. Medium 

CSS3889943 The validation table for SAP ECC control keys does not exist.  Medium 

CSS416669 Incorrect message when copying operations if the first operation contains all 
zeroes.  

Medium 

CSS465480 Tool plan is being saved with Schedule Order Data (which is required) blank. High 

CSS47349 Unable to close subdocument window after printing. Medium 

CSS475485 Unable to export installation and fab plans. Medium  

CSS83041 Error message appears when find and replace is attempted. Medium 

CSS927298 When copying a step, the title is being overwritten. Medium 

CSS950807 Within CAPP tables, if you have more rows than are visible for multiple screens, 
selecting page down will move the tables a page down plus one row, which causes 
users to miss one row. 

Low 

ITS38743 Fab plan has open signoff lines but the plan is in Complete status. High 

ITS40540 System does not send email notifications but signoff indicates notification has 
been sent. 

High 
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SAP 
Reference 

Description Priority 

ITS42447 MFG link to DESIGN not working for a null Tool Series. High 

ITS42796 Standard process does not copy operation configuration when added to plan. High 

ITS43233 Unable to create a fab rework plan. Low 

ITS43370 Last logged on message is corrupt (date/time issue). High 

ITS43507 
and 43960 

Search errors when using Process Doc Id query. High 

ITS43827 User can add/change header notes for an order/plan in OM and CAPP without 
editing the plan/order itself. 

Medium 

ITS44563 Error message after clicking Close in the upper-right corner. Medium 

ITS45252 Issue in proc ::hmsCappInit::ConfigureCappMandatoryWidgets. Medium 

ITS45333 Copy and paste of header note data collection tables does not save correctly. High 

ITS45474 Oracle error when exporting to XML. High 

3.1.3 MCM 

SAP 
Reference 

Description Priority 

CSS134714 A query in the application is returning {ORA-01036: illegal variable 
name/number}. 

Medium 

CSS700458 Plan has implement status with hold notes, but the signoff shows approved. 
Cannot save plan complete. Order cannot be released. 

High 

ITS39689 Deleting a line in the Execution Signoff cycle causes a unique constraint error. Low 

ITS41744 Database error when clicking on action items. High 

ITS42003 Updating an action item in the Execution phase—double-clicking in any date field 
does not pop-up a calendar for date entry. 

Low 

ITS43321 
and 770489 

Error while completing a change record. Medium 

ITS43389 No validation for Planned As and for Planned Next Assy fields in the Update Part 
Data dialog box. 

High 

3.1.4 OM 

SAP 
Reference 

Description Priority 

CSS465630 Unable to perform OM on an order. High 

CSS700126 Plan precedence performance. Medium 
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SAP 
Reference 

Description Priority 

CSS724880 User name required to go into OM from SFM. High 

CSS878555 Cannot save complete in OM. Medium 

ITS41412 Incorrect error message when retrieving an order (search by Authority field). Medium 

ITS43096 Copy standard operation error. Retrieve From Plan function caused prior 
condition for hiding the Retrieve Standard button to break. 

High 

ITS44136 Order not saving complete. Operation cannot be found error. High 

ITS45404 Parts are disappearing from the Parts List when modifying operations in OM. High 

3.2 Execution Modules 

3.2.1 SFM 

SAP 
Reference 

Description Priority 

CSS1000351 Standard text data collection or skipping a step focus issue in Execution 
Operations: SFM window appears in front of Execution Operations, which fails to 
auto-refresh. 

Medium 

CSS1023466 Order Status function key focus issue. Medium 

CSS1032946 In a standard text table, the initial row is not immediately visible in Execution 
Operations. The user must click the white space below the table to see the row. 

Medium 

CSS1057180 Execution Operations row not highlighted. Low 

CSS1126142 Standard text audit history is created for Not Started steps. Medium 

CSS1126828 An operation is completed with a skippable step. A user than undoes the skip. The 
operation remains completed but the step is now in Not Started status. 

Medium 

CSS1127329 When performing a buyoff and then immediately using the scrollbar, some users 
experienced a system lockup. 

Medium 

CSS1129982 Loading and viewing orders in Execution Operations is taking 30+ seconds. Medium 

CSS1141816 The Activity History window opens behind SFM or the Execution Operations 
window. 

Medium 

CSS1152012 Shop supervisors cannot stop labor for their employees and receive an error. Medium 

CSS119285 Error: Window name “sw” already exists in parent. Low 

CSS119613 Error: can’t read _hmsShopDisplay_stepPaneAssociation. Low 

CSS126624 When launching SFM from the main menu and navigating to the Order Status 
screen, the Search Criteria and Refresh Data buttons do not appear. 

Medium 

CSS136553 Shop Notes 250 character limit problem. Medium 

CSS146103 The WIP CCRT appears to be splitting quantities off of the parent order instead of 
copying the parent order to the CCRT order and then closing the original parent 
order. 

High 



 

SAP Complex Assembly Manufacturing, Release 7.2, Service Pack 2 
Issues Addressed 

Release Notes 
© 2015 SAP AG or an SAP affiliate company. All rights reserved. 40 

 

SAP 
Reference 

Description Priority 

CSS151516 Cannot add a charge number. Medium 

CSS169163 Changed work center import to use LOIWCS02 IDoc instead of LOIWCS03. Medium 

CSS171826 Get MakeDirectMiddlewareCall returned a status of BAPI call failed error when 
trying to close an operation. 

High 

CSS1734530 Error when selecting NCR List on the dashboard. Low 

CSS187821 Project number does not appear in Labor Activities, and after viewing Labor 
Activities errors arise as user navigates SFM. 

Medium 

CSS20226 SFM menu option Help > About Shop Mgmt yields the error ::hmsGui: AboutBox 
not defined properly. 

Medium 

CSS212132 Batch mode operation constraints are causing operation status confusion.  Medium 

CSS2298419 Serial number collection failure. High 

CSS232060 Get a database error when unchecking Show All Orders in Execution Operations. High 

CSS2344496 Order tree disappears after collecting data in Execution Operations. Medium 

CSS240729 Job Queue not working properly. High 

CSS2590944 Error on attempt to call Execution Operations. High 

CSS264170 Error while transitioning from SFM to the main menu. Medium 

CSS2663369 Error appears when switching between CAPP, SFM, and Execution Operations. Medium 

CSS2767053 Database error creating bookmarks in Execution Operations. Medium 

CSS304745 User setting of work location is not saved in the Assembly Dashboard. Medium 

CSS304837 Second process percent complete transaction by a different user on the same 
operation does not get executed. 

High 

CSS318511 User is stuck at lunch if an order is closed, scrapped, or cancelled while the user is 
at lunch. 

Medium 

CSS3228010 System loses focus on Execution Operations.  Medium 

CSS334561 Serialized parts data entry issue. Medium 

CSS3642441 SFM profile not being stored. High 

CSS374967 Audit verification Earned Standards SAP Complex Assembly Manufacturing vs. 
SAP ECC: For the ConvertPercentHours proc, it seems that if the standard hours 
are less than 1.0000, then the process is returning #0.0000# instead of 
#100.0000#. 

High 

CSS379547 Hard-coded column name for the SD_OPER_STEP_SUMMARY table. Medium 

CSS379547 SQL error in Shop Display. Medium 

CSS407056 Main menu will not open from SFM or Execution Operations. Medium 

CSS418712 WIP_SERIALIZED_PARTS table being corrupted. High 

CSS466069 The Assembly Dashboard locks up due to Tcl syntax error. Medium 

CSS466079 Standard text fields are unusable in Execution Operations. Medium 

CSS470828 Completing an operation while another user is at lunch does not allow the user to 
return from lunch. 

Medium 
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SAP 
Reference 

Description Priority 

CSS47442 Database error when viewing an order in Execution Operations. Medium 

CSS47442 Database error appears when viewing an order in Execution Operations. Medium 

CSS480226 Started batch still sending start messages. Medium 

CSS489496 Error while trying to enter a serial number. High 

CSS489563 Redundant standard text audit history. Medium 

CSS501665 Need to save first before entering data in a batch. Medium 

CSS518660 The Shop Display screen appears instead of the Work Queue. Medium 

CSS520799 Activity History does not show the order start when the first operation is started. Medium 

CSS538801 The Assembly Dashboard queries twice. Medium 

CSS554130 Deleting an order should delete related items from WL_ORDER_WORK_LOCATIONS. Medium 

CSS568100 Continue charging setup message after stopping setup charging. Medium 

CSS599521 Labor Activities inquiry performance. Medium 

CSS621873 Calculate formula is not working. Medium 

CSS621923 Browser order is missing data. Medium 

CSS641133 Cannot change user or logon profiles. Medium 

CSS662032 Complete sequence giving an error. Medium 

CSS671489 Stuck in standard text once it has been clicked on in a nonstarted operation in 
Shop Display. 

Medium 

CSS681751 Batch scan enter is not working Medium 

CSS806087 Get an Oracle 999 error when trying to view the Assembly Queue. Medium 

CSS815989 Step description is missing in Shop Display and Execution Operations. Medium 

CSS83349 When switching between Execution Operations and Order Status using the F5  key 
to refresh Order Status, the system locks up. 

Medium 

CSS840683 Execution Operations screen display error—none of the detail text appears. Medium 

CSS888050 Archive issues—archival process and viewing.   Medium 

CSS937374 Execution Operations cannot initialize drop-down data collection fields. Medium 

CSS949183 Concurrent users cannot execute on the same order. Removed the lock on the 
WIP_ORDER table as part of the Complete Operation activity as it was not 
necessary. 

High 

CSS949943 Operation not found error in Execution Operations. Medium 

CSS957861 Error when scanning barcode on Shop Display screen. Medium 

CSS958361 Batch: No option to return from lunch Medium 

CSS981530 Application title does not change. Low 

ITS38386 An unexpected error appears when user entered incorrect password. Medium 

ITS39273 Replace removed part with a different serial number. Low 

ITS40570 Get database error when trying to save changes in Screen Configuration. High 
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SAP 
Reference 

Description Priority 

ITS40617 Entering invalid UID clears or changes the Serial Number field on the Serialized 
Parts dialog box. 

High 

ITS40773 Order split performance is extremely slow for serialized orders. High 

ITS40881 Cannot consume a serialized installation kit parent part. High 

ITS40938 Ready and complete quantities are incorrect after a split is performed on a 
partially completed operation. 

High 

ITS40973 Serialization drop-down—currently there are duplicates due to a rework order 
type. 

High 

ITS40978 System generates no error message for an incomplete part number sent to SAP 
Complex Assembly Manufacturing; need an error message to find cause of the 
defect. 

High 

ITS40994 Order/operation closure is allowed when auxiliary data is not completely 
collected. 

High 

ITS41397 Issue with the ready quantity for splits that have been in Order Maintenance. High 

ITS41455 Scrap is failing because the interface cannot close the NCR. High 

ITS41594 Oracle SerialCollectorHelpers.BuildPartsMatrix package runs very 
slowly. 

Low 

ITS41677 Can’t read "parentComplete": no such variable error. High 

ITS41729 Order cancel is not working if the order is on hold. High 

ITS41767 Incorrect part ID number in generated UII. High 

ITS41791 Error message after clicking Show orders for plan button in Acknowledgement 
screen. 

High 

ITS41865 Related orders issue for tool orders. High 

ITS41878 Show orders for plan button error. High 

ITS41924 Split failed in SAP MII—error message Unable to compute critical ratio. High 

ITS42060 Error message prevents creation of unplanned removal—legitimate serial 
duplication. 

High 

ITS42126 Application not handling the unplanned removal scenario properly where a 
part/cage has multiple Part Masters, one UID and one not UID, and the part is not 
installed with a UID. 

High 

ITS42185 Recording serial numbers that exist in the WIP_SERIALIZED_PARTS table with 
AVAIL_FOR_COLLECTION flag = 0 fails. 

High 

ITS42233 Cannot cancel an IK order. High 

ITS42256 Getting a database error while collecting serial data. High 

ITS42315 Header notes with a 0 change alert value show up for acknowledgement. Low 

ITS42503 The Related Order dialog box no longer displays data for disposition orders. High 

ITS42945 Specific MBOM configurations result in serial data loss in SFM when performing 
specific unplanned removal activity 

High 

ITS43122 Move the Go To Lunch information message so that it appears after the post 
event. 

Low 
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SAP 
Reference 

Description Priority 

ITS43200 Stop messages for clocking off. Low 

ITS43209 UID format is inconsistent when collecting parent serial number. High 

ITS43218 Activity history messages are not displaying correctly. High 

ITS43222 Translation error when typing in incorrect UID number. Medium 

ITS43311 Serial/UID not stable. High 

ITS43326 LOIPRO transaction fails in SAP MII; unable to create an order. High 

ITS43332 ZB_LOIPRO_CANCEL transaction fails in SAP MII; unable to cancel an order. High 

ITS43354 Receive serialization error when attempting to complete resubmit disposition 
when no serialization exists. See the Enhancements section for two new 
configuration parameters created for this issue. 

High 

ITS43380 Receive an error when retrieving and trying to re-install a part on an unplanned 
removal record. 

High 

ITS43421 Impossible to create an order using Create Linked Order. High 

ITS43505 Remove the check for required order quantity when moving an operation. Low 

ITS43631 Extra messages on Batch Order Scan cancel. Low 

ITS43677 Proper lunch error is not presented. High 

ITS43678 Incomplete message after return from lunch. Low 

ITS43780 UID generation overrides collected UID information. High 

ITS43828 Incorrect error message when clicking in a data field in Shop Display for a 
nonstarted operation. 

Low 

ITS43850 The OK button does not save the changes when removing serials for planned 
removal parts. 

Low 

ITS43862 
and 43968 

Can’t save a duplicate serial. High 

ITS43904 Generating a UID in manual data entry mode does not allow entry of a CAGE code; 
the CAGE code is defaulted to 00000. 

High 

ITS43970 SFM was/is order compare does not display all the components of an order. High 

ITS43972 Unplanned removal re-installed part is not enforcing UID requirements. High 

ITS43973 Invalid construct error on unplanned removal record. High 

ITS44134 The Order Operation Parts List dialog box does not appear in Shop Display. High 

ITS44354 Resubmit functionality not working due to multiple database entries in the 
NCM_DISPOSITION_BUYOFF table. 

High 

ITS44391 SFM is not working—database errors on the Order Status and the Work Queue 
screens.  

High 

ITS44763 The Assembly Dashboard is not accessible. High 

ITS44781 Incorrect error message displaying when user attempts to cancel an NCR from a 
resubmit. 

Low 

ITS44998 Two part order for serialized detail closed without recording the serial number. High 
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Reference 

Description Priority 

ITS45337 Activity History date/time sort does not work correctly. High 

ITS45394 replan to standalone of a closed discrepancy item does not show REPLANNED in 
SFM NCR list, 

Low 

3.2.2 NCM 

SAP 
Reference 

Description Priority 

CSS885923 No data found when trying to retrieve a rework plan. Medium 

ITS40947 Error message displayed when retrieving NCM records. Low 

ITS42746 Retrieve screen error when searching by NCR create date. High 

ITS43098 Parent order with serial/UID is not recognized in NCM when trying to write an 
NCR. 

High 

ITS43397 Incorrect error message when adding an NCR. Low 

ITS43477 System is displaying incorrect information in Nonconformance Management 
(Parts and Tooling). 

High 

ITS43482 When rejecting an NCR, the system is closing items in the signoff, which is limiting 
the ability to process the NCR. 

High 

ITS43514 System is not enforcing entry of mandatory data for rejection comments. High 

ITS43564 Expected signoff information message is missing. Low 

ITS43710 System is no longer displaying date and time stamp in NCM when Shop and 
Inspection Notes are added in SFM to a disposition order. 

High 

ITS44751 NCR Header and Discrepancy Signoff functionality allowing user to change group 
and continue to edit NCR. 

High 

ITS45034 Retrieving: cannot search using low and high values for some fields. Low 

3.2.3 PMI 

SAP 
Reference 

Description Priority 

CSS1079536 Updated setup and run times in OM are not updated in schedule. Medium 

CSS220261 Open project plan performance issue. Medium 
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3.3 Common Modules 

3.3.1 CB 

SAP 
Reference 

Description Priority 

CSS715110 The Callboard Maintenance dialog box responds extremely slowly upon user or 
work location update. 

Medium 

ITS40969 Freeform call error when selecting from menu bar. Low 

ITS43365 Callboard locks up on freeform calls if group is changed when selecting sub-
group. 

High 

3.3.2 FAI 

SAP 
Reference 

Description Priority 

CSS830450 FAI requirement on an order applies even if the order is not started. Medium 

CSS906744 Plan revision is not displayed in the First Article Requirement Record (FARR). Medium 

ITS35181 Disable the question A First Article Inspection will need to be performed.  Do you 
wish to proceed with starting order? on order start. 

High 

ITS40113 Sort does not work properly. Low 

ITS40451 Error received when trying to retrieve a FARR on plan revision 2. High 

ITS42046 Recommended Inspection Method: When this contains standard text, different 
results are seen depending on whether a variable data field or a table is used. 

Low 

ITS42242 Update to correct issues revolving around creating FARR iterations. Low 

ITS42365 Error received when trying to copy FARR characteristics from another FARR. High 

ITS42477 Error when right-clicking on FAIR graphics section. Low 

ITS43211 After collecting the serial number and buyoff off the FAI, the serial number was 
not saved. 

Medium 

ITS43343 Move FAI dialog box is not usable. High 

3.3.3 TC&A 

SAP 
Reference 

Description Priority 

CSS216641 Mandatory data check failing. Medium 
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3.3.4 TSM 

SAP 
Reference 

Description Priority 

CSS1083784 When selecting multiple rolls of material for issue, the TSM Issue Material screen 
does not default to Return Allowed. When selecting a single roll, it does default to 
Return Allowed. 

Medium 

CSS1103922 TSM kit Location drop-down does not populate with all the locations for available 
kits. 

Medium 

CSS1128702 Multi-row database error when extending TSM. Medium 

CSS138043 User can change the Return Allowed check box, which should be disabled. Medium 

CSS140258 It is possible to modify fields on the Return Material screen; after that returning 
does not function properly. 

High 

CSS140362 There is no vertical scroll bar on the Return Material screen. Medium 

CSS222062 Printing the TSM Layup Panel: Clearing the All Sections check box and selecting 
All Layups returns a blank print out. 

Medium 

CSS2897762 Unnecessary ":PM" value is added to Exp Date field causing a database error. Medium 

CSS2902382 Material is cleared from the Issue Material screen after selecting the Work Center 
option. 

Medium 

CSS3477269 Unable to receive multiple rolls. Medium 

CSS3545313 Original Expiration Date column is empty on the Order Ply List. Medium 

CSS435832 System is allowing orders to complete and setting ply table complete even though 
a kit has not been issued to the order. 

High 

CSS438456 The Issue Time Sensitive Material / Ply Kit screen is not displaying materials that 
have already been assigned to the order. 

High 

CSS4777625 Changes are not saved when modifying plies in CAPP. Medium 

CSS642706 TSM changes status after plies complete. Medium 

CSS725420 Sort on expiration date in TSM Storage Module is sorting alphanumerically, not by 
date. 

High 

CSS793504 The expire function is calculating expiration on inactive material. Medium 

ITS40812 TSM expired order ply does not prevent closing Compact or Complete operations. High 

ITS42439 Printing the TSM Layup Panel is not working properly. Low 

3.3.5 Shared 

SAP 
Reference 

Description Priority 

CSS1152340 Smart card interface does not work. High 

CSS146304 Interface failures: I-1083: Error message: WebService call succeeded. Interpreters 
encountered an exit event during startup: No more menus can be allocated. 

High 
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Description Priority 

CSS171549 Cannot create an order for a serialized/lot controlled part from XML. High 

CSS2705374 Cannot change mandatory colors. Medium 

CSS372515 Including LDAP package requires ASN, which is missing. High 

CSS3788409 Integration to Visual Enterprise Generator fails. Medium 

CSS3883966 Unable to install print/batch services. Medium 

CSS47425 Two or more message boxes are not shown correctly. Medium 

CSS588239 When creating a material master via the interface, the business rules need to be 
revised to send the material masters to the correct BOM header. 

Medium 

CSS700933 Standard text Quantity Sensitive check box defaults to selected, cannot save if the 
check box is cleared. 

Medium 

CSS71011 The field LAST_LOGIN_DATE in table HMS_USERS is not being filled in for all the 
ways a user can log into SAP Complex Assembly Manufacturing. 

Medium 

CSS79776 Email Notification does not work correctly. Medium 

CSS806129 Cannot delete a profile. Medium 

CSS841005 Disabling Delete All Redline for profiles is not working. Medium 

CSS92861 Cognos report execution results in Wait message and then application freezes. Medium 

ITS40781 SAP Complex Assembly Manufacturing to SAP ECC interfaces need to use new 
CAMS-INT/MII transactions. 

High 

ITS41599 In Signoff Cycle Maintenance, unable to copy signoff cycle to a different document 
type. 

Low 

ITS42620 Break Link option should not be available for standard plans. Low 

ITS42695 Making program inactive prevents editing. Low 

ITS42794 When searching for text using the Find Oper Text functionality, the Go To Text 
button does not select the correct text if the text is preceded by a standard text 
table in the operation. 

High 

ITS42789 Seeing debug messages in the console when debugging is not enabled. Medium 

ITS42973 The system is not saving profile permission setting in a consistent manner. 
Depending on the method selected, the system may not save the settings. 

High 

ITS42979 Language not working with default window language settings; FR locale is 
missing. 

High 

ITS43005 Recursive Source sources files into ::hmsTools:: namespace instead of the 
global namespace, which causes problems with message catalogs and other 
namespace sensitive code. 

High 

ITS43371 VE Interface Map produces errors. Low 

ITS44287 Unable to change the value of Node Code using the event proc PostStdTxtCopy. Low 

ITS44375 Error in proc ::hmsUtilities::EffectivityArrayEquals. High 
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3.3.6 Known Issues 

 

The following table lists enhancements with known issues encountered during testing of this release as well as any 
workarounds available. 

SAP 
Reference 

Description Workaround 
Available 

ITS40960 Change alert comparison  

ITS44028 Kit enhancements  

ITS42737 3D import success indicator  
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